How to Fix Lag

KIXEYE Swag
KIXEYE Swag
Unicorn Overlord
Joined Nov 2011 Posts: 3,665
edited 12 Jul 2012, 3:03AM
Greetings Captains,

We're currently investigating lag issues you reported yesterday. We believe it may have to do with the latest version of Flash (11.3), which introduced the ability to type in full-screen.

If you are having an issue with lag or full-screen mode, we recommend that you revert to this previous version of Flash:

http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp_11.2.202.233_archive.zip

Be sure you clear your cache and that browser completely restarts.

If you are subsequently still having issues, there are few more things you can try:

• Right-click to disable hardware acceleration in the Flash settings.
• Right-click to increase the memory cache in the Flash settings.
• Temporarily disable your firewall and/or antivirus software.
• Close any other programs you have that are accessing the Internet (other browser windows, any file downloads, other games, etc.)
• Check your Facebook Security Settings. Under Account, select Account Settings, then Security, and see if Secure Browsing is enabled. You may wish to try disabling this to see if it helps.
• Contact your Internet Service Provider to see if they can assist you.

If after doing all this you are still having issues, please post the following information below:

• Your FB User ID and when you're encountering lag
• Your system specs (OS, CPU, RAM, Graphics Card, HDD space).
• Type of Internet connection.

Thanks for your assistance in this matter.
  • RIDdler
    RIDdler
    Minor Nuisance
    Joined Dec 2011 Posts: 244
    ive never experienced lag. ever.
  • James Thomas Ellison
    James Thomas Ellison
    Strike-force Captain
    Joined Jan 2012 Posts: 945
    LOTS of lag today. Has taken on average 30 seconds to engage a base
    It's a pirate game, quit your cryassing already 
  • caribbean girl
    caribbean girl
    Unicorn Overlord
    Joined Nov 2011 Posts: 5,964
    did that 2 nights ago..downgraded to 10
    not a normal gal...xoxo
  • eze
    eze
    Unicorn Overlord
    Joined Aug 2011 Posts: 7,177
    I uninstalled flash completely from my system (Ubuntu 10.04 LTS), which reverts my flash back to the default version that comes with the OS. It helped a tiny bit but there is still a substantial delay when engaging in battle and when collecting resources from salvages.

    This lag has been going on ever since the "big graphics update" and has only increased with the latest release of Flash. Flash may be partially at fault, but it's not the complete root of the issue.
  • NuclearFallout
    NuclearFallout
    Unicorn Overlord
    Joined Aug 2011 Posts: 8,431
    Greetings Captains,

    We're currently investigating lag issues you reported yesterday. We believe it may have to do with the latest version of Flash (11.3), which introduced the ability to type in full-screen.

    If you are having an issue with lag or full-screen mode, we recommend that you revert to this previous version of Flash:

    http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp_11.2.202.233_archive.zip

    Be sure you clear your cache and that browser completely restarts.

    If you are subsequently still having issues, there are few more things you can try:

    • Right-click to disable hardware acceleration in the Flash settings.
    • Right-click to increase the memory cache in the Flash settings.
    • Temporarily disable your firewall and/or antivirus software.
    • Close any other programs you have that are accessing the Internet (other browser windows, any file downloads, other games, etc.)
    • Check your Facebook Security Settings. Under Account, select Account Settings, then Security, and see if Secure Browsing is enabled. You may wish to try disabling this to see if it helps.
    • Contact your Internet Service Provider to see if they can assist you.

    If after doing all this you are still having issues, please post the following information below:

    • Your FB User ID and when you're encountering lag
    • Your system specs (OS, CPU, RAM, Graphics Card, HDD space).
    • Type of Internet connection.

    Thanks for your assistance in this matter.
    Thank you for this thread, hopefully people will learn now that Kixeye isn't responsible for the lag.
    "Do not pray for easy lives. Pray to be stronger men."
    - John F Kennedy 

    "If you're explaining, you're losing"
    Ronald Reagan

    No I'm not a moderator
  • caribbean girl
    caribbean girl
    Unicorn Overlord
    Joined Nov 2011 Posts: 5,964
    Flash may be partially at fault, but it's not the complete root of the issue

    Have to agree..def not only flash...right now i cant even see the next base!
    not a normal gal...xoxo
  • NuclearFallout
    NuclearFallout
    Unicorn Overlord
    Joined Aug 2011 Posts: 8,431
    shri wrote: »
    Have to agree..def not only flash...right now i cant even see the next base!
    I think flash is the problem, adobe shockwave is what I switched to and I have had no lag since using it.
    "Do not pray for easy lives. Pray to be stronger men."
    - John F Kennedy 

    "If you're explaining, you're losing"
    Ronald Reagan

    No I'm not a moderator
  • PRICEisWRONG
    PRICEisWRONG
    Minor Nuisance
    Joined Oct 2010 Posts: 276
    Swag, the lag issue is with the amount of time it takes to engage. Once I'm in battle, everything is fine. In the scenario in which I want to hit a salvage, my boat responds immediately by heading toward the salvage. Once it gets there, it typically takes 30 seconds or more for the battle to initiate.

    I am one that put in a ticket yesterday. The issue then occurred when I attempted to engage an invader. Obviously, nothing happened. I went to refresh my game by restarting it. As I came back, I was informed I was in battle. I wen to the world map where my boat was glowing red. Until the persons fleet I was fighting actually showed up, I didn't get the option to join. When I finally did get to join, my 2 remaining boats were pinched. One died immediately thereafter, and I managed to pull one away with no health. A bit of splash did kill that boat as well, but it was a full health fleet prior to that battle.

    The server appears to be server side, but I will continue making changes on my end, and report back if anything makes a difference.
    Former BP Celeb
  • Michael Middleton
    Michael Middleton
    Strike-force Captain
    Joined Jun 2011 Posts: 812
    have no Lag in games but huge lag in engaging things takes forever to get into a fight
    My piece of Battle Pirates Fan Fiction: http://forums.kixeye.com/threads/125229-The-Battle-Pirates-story Hope you enjoy!!

    My second piece of Battle Pirates Fan Fiction[url] http://forums.kixeye.com/threads/196200-Owen-s-shipyard?p=1716922#post1716922 [/url] Hope you enjoy!!!
    Sortar wrote: »
    haha what an idiot..more money for king will and his tribe of merry idiots...you guys complain then just spend more...classic..
  • KIXEYE Swag
    KIXEYE Swag
    Unicorn Overlord
    Joined Nov 2011 Posts: 3,665
    This is not a thread to complain. Unless you are posting the information I asked for, your post will be removed.
  • coorsman_99
    coorsman_99
    Potential Threat
    Joined Feb 2012 Posts: 30
    Question how do you get to type on comms in full screen? It wont let me do that and I did the new flash update.
  • SatansSpawn
    SatansSpawn
    Minor Nuisance
    Joined Feb 2012 Posts: 261
    ive updated to the 11.2 but i get the update is out of date and is blocked any way to by pass this in chrome
  • Ollie99
    Ollie99
    Incursion Leader
    Joined Jan 2012 Posts: 1,175
    This is not a thread to complain. Unless you are posting the information I asked for, your post will be removed.

    Don't know what the hell was so different about my post that it got removed and many others didn't, but okay, yall do whatever you feel like on here I forget that some times. Not everyone knows the things your asking about Swag we don't all do this for a living. But I'll do my best, HP pavilion g7 6gb and 8gb don't remember which is Ram or memory or whatever. No idea about HDD space, or what graphics card I have. Lag hasn't been a bad issue lately, until today. And believe it or not my last post was intended to be as informative as it could be regarding the issues i'm having and when they started, given my limited computer knowledge. I've done all you recommended regarding my system, except the firewall and virus stuff which ain't gonna happen. I'll post again with more info for you once i've consulted my IT guy...

    id#2947533
    windows 7
    dual core AMD Radeon graphics.
    "high speed" cable internet connection through road runner.
    "Whoever said laughter is the best medicine never had gonorrhea."

    Mel Brooks

    Sectors: Too many to remember off the top of my head.

    lvl: 33, I think.
  • Man Tim
    Man Tim
    Unicorn Overlord
    Joined Jul 2011 Posts: 5,372
    Oh so there is a new 11.3? good I didn't update it lol... mine is still 11.2 so it works fine, and since I haven't turn my comp off for a week, i guess i missed the update. good to know
  • Magic Bunny
    Magic Bunny
    Unicorn Overlord
    Joined Sep 2011 Posts: 17,465
    User Id 1487956

    tried what you said and already submitted a ticket

    no success - lag affects ships moving on world map and in combat; when base hitting ships can be invisible and an "incoming rocket" starts counting down form about 8000??? - unable to hit bases for 2 days

    Acer 5750 i5-2430M 2.4ghz; Intel graphics 3000; 500Gb Hdd; Windows 7

    there have been lots of microsoft OS and Office updates since sunday to my laptop
    Level ... not enough fingers to count that high

    First played July 2011, in sector 96

  • PRICEisWRONG
    PRICEisWRONG
    Minor Nuisance
    Joined Oct 2010 Posts: 276
    • Your FB User ID and when you're encountering lag
    • Your system specs (OS, CPU, RAM, Graphics Card, HDD space).
    • Type of Internet connection.

    There is delay when engaging. When I target a salvage, my fleet immediately responds by heading in that direction, but then stalls when it gets there. The stall time has been 30seconds or longer. Same when I hit a base.

    System Specs...
    OS: Windows 7 Ult. 32 bit
    CPU: Q6600 @ 2.4GHz
    RAM: 4GB
    Graphics Card: BFG Nvidia 8800 GT OC w 512MB DDR3
    HDD Space: 215GB free on 250GB Partition

    Internet: Cable Modem 15Mb/2Mb
    2007326923.png
    64588110.png
    Former BP Celeb
  • Kal-EL
    Kal-EL
    Minor Nuisance
    Joined Oct 2011 Posts: 123
    I had so much lag last night that my last base attack sent me into spectator mode instead of playing the game. The maps and islands still load slow since the update...when will this be fixed Swag? The graphics update took this game down several notches in playability. When we attack bases its nearly a full minute waiting for the join battle menu opens. I hardly think this is all due to Adobe Flash update. Those issues happened BEFORE Adobe Flash update. I took my browser back to the previous version step by step as you suggested.....still all the same lag. Kixeye not acknowledging the problems before the Adobe update doesn't make us not believe they are there.
  • Thomas Sakkuna Erland
    Thomas Sakkuna Erland
    Potential Threat
    Joined May 2012 Posts: 88
    Greetings Captains,

    We're currently investigating lag issues you reported yesterday. We believe it may have to do with the latest version of Flash (11.3), which introduced the ability to type in full-screen.

    If you are having an issue with lag or full-screen mode, we recommend that you revert to this previous version of Flash:

    http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp_11.2.202.233_archive.zip

    Be sure you clear your cache and that browser completely restarts.

    If you are subsequently still having issues, there are few more things you can try:

    • Right-click to disable hardware acceleration in the Flash settings.
    • Right-click to increase the memory cache in the Flash settings.
    • Temporarily disable your firewall and/or antivirus software.
    • Close any other programs you have that are accessing the Internet (other browser windows, any file downloads, other games, etc.)
    • Check your Facebook Security Settings. Under Account, select Account Settings, then Security, and see if Secure Browsing is enabled. You may wish to try disabling this to see if it helps.
    • Contact your Internet Service Provider to see if they can assist you.

    If after doing all this you are still having issues, please post the following information below:

    • Your FB User ID and when you're encountering lag
    • Your system specs (OS, CPU, RAM, Graphics Card, HDD space).
    • Type of Internet connection.

    Thanks for your assistance in this matter.


    Hi swag i did complete the list, atleast what i could and i still have the lag issue. I had the lag for the last 3 days. Problem is really only to engage the battles, once im in its fine and everything response imediatle.

    User ID is: 4823688 Lag last three days
    Using FireFox, 4gb RAM 450gb free of 500gb, not sure about Graphics card and CPU bec im not that into it but its a new computer.
    Internetconnection: Broadband 20mb down/1mb up


    Tnx Swag
    Thomas_Bloodlust

    Level : 49 Current Sector : 341
    Visited Sectors : N/A
    Home Sector : 341
  • Ninefingers
    Ninefingers
    Skilled Warrior
    Joined Sep 2011 Posts: 359
    User Id: 2420204
    OS: Windows 7 Ult. 64 bit
    CPU: i7 @ 3.5GHz
    RAM: 8GB
    Graphics: Nvidia GTX 460 1GB
    Cable Broadband 12MB/2MB

    The problem isnt Adobe Flash and certainly not people's systems as you can see from my specs on my home desktop.

    I use a mobile modem at work and prior to the last two weeks I was averaging around 3.5 GB of bandwidth a month for BP only. Today I hit 5 GB and I still have 1 week left for the end of the month. Swag, you guys are pushing more data out or this wouldn't have happened. The additional data (whatever it is) is slowing the whole system down. Please stop treating your paying customers like idiots. This problem is on your all's end.
  • Bob C
    Bob C
    Potential Threat
    Joined May 2012 Posts: 27
    Greetings Captains,

    We're currently investigating lag issues you reported yesterday. We believe it may have to do with the latest version of Flash (11.3), which introduced the ability to type in full-screen.

    If you are having an issue with lag or full-screen mode, we recommend that you revert to this previous version of Flash:

    http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp_11.2.202.233_archive.zip

    Be sure you clear your cache and that browser completely restarts.

    If you are subsequently still having issues, there are few more things you can try:

    • Right-click to disable hardware acceleration in the Flash settings.
    • Right-click to increase the memory cache in the Flash settings.
    • Temporarily disable your firewall and/or antivirus software.
    • Close any other programs you have that are accessing the Internet (other browser windows, any file downloads, other games, etc.)
    • Check your Facebook Security Settings. Under Account, select Account Settings, then Security, and see if Secure Browsing is enabled. You may wish to try disabling this to see if it helps.
    • Contact your Internet Service Provider to see if they can assist you.

    If after doing all this you are still having issues, please post the following information below:

    • Your FB User ID and when you're encountering lag
    • Your system specs (OS, CPU, RAM, Graphics Card, HDD space).
    • Type of Internet connection.

    Thanks for your assistance in this matter.



    Could someone explain in plain english just how to go about using the flashplayer link posted above. Not real computer savvy, but willing to try anything to resolve the lag issue.....
  • IndyMike
    IndyMike
    Potential Threat
    Joined Oct 2011 Posts: 94
    64590393.png
    http://www.speedtest.net/result/2007385901.png

    I have done everything prescribed (feeling naked without firewall and antivirus) and still same results as the last 5 days. Have sent a ticket too, including screenshot of me refreshing and then landing in sector 1 on top (or bottom) of hundreds of others. What a mess.
    Battle Pirates Level 63
    User ID 2344048
    FireFox
    Windows 7
  • Gary_M
    Gary_M
    Skilled Warrior
    Joined Aug 2011 Posts: 362
    Greetings Captains,

    We're currently investigating lag issues you reported yesterday. We believe it may have to do with the latest version of Flash (11.3), which introduced the ability to type in full-screen.

    If you are having an issue with lag or full-screen mode, we recommend that you revert to this previous version of Flash:

    http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp_11.2.202.233_archive.zip

    Be sure you clear your cache and that browser completely restarts.

    If you are subsequently still having issues, there are few more things you can try:

    • Right-click to disable hardware acceleration in the Flash settings.
    Right-click to increase the memory cache in the Flash settings.
    • Temporarily disable your firewall and/or antivirus software.
    • Close any other programs you have that are accessing the Internet (other browser windows, any file downloads, other games, etc.)
    • Check your Facebook Security Settings. Under Account, select Account Settings, then Security, and see if Secure Browsing is enabled. You may wish to try disabling this to see if it helps.
    • Contact your Internet Service Provider to see if they can assist you.

    If after doing all this you are still having issues, please post the following information below:

    • Your FB User ID and when you're encountering lag
    • Your system specs (OS, CPU, RAM, Graphics Card, HDD space).
    • Type of Internet connection.

    Thanks for your assistance in this matter.

    I posted a thread in the support forum when the problems first were discovered a few weeks ago that the game doesn't store any at all on my computer but I never got a reply. http://forums.kixeye.com/threads/213853-Local-Flash-storage

    Is this normal? My son plays other flash games and they store info. I check regularly and it always has 0 KB used.

    Edit: the pic I included in that thread was farked, so here's a current one.

    vz2w0.png
    Grimnir - lvl 56
  • ark
    ark
    Strike-force Captain
    Joined Oct 2011 Posts: 1,056
    i have flash player 11.3 and i cant chat in full screen, plus i have next to no lag never get sos screen and hardly get white screen
    Warrior_Angel...level 30...sector 491...my base location:294174,72
    BI 5: winner of strike cruiser...BI 6: winner of HH-A

    http://support.kixeye.com/mail/
    The only thing this changes for you, if you are a high level player, is hitting bases so low that you have no business hitting them. What's the phrase... try picking on someone your own size?
  • fluke330
    fluke330
    Greenhorn
    Joined Jun 2012 Posts: 1
    Untitled.jpg



    i have been having problems on and off for a month, so i bought a new laptop with a pretty decent spec.

    i am still having problems with the new laptop.
    sector 330
    user id: 3080668
    internet explorer
    my download is 20+mbps and my upload is 3.7mbps.
    the following link is for the info you requested on my system
    http://uk.computers.toshiba-europe.com/innovation/product/Satellite-L850-161/1123798/toshibaShop/false/
  • Joe Oliveiro
    Joe Oliveiro
    Minor Nuisance
    Joined Dec 2011 Posts: 155
    Swag,

    Don't take this as an attack on kixeye because it really isn't. You are once again blaming the users and their rigs for the lag issues.

    All day today I was playing just fine. No lag. I was able to lock a salv in roughly 1 second or less. Right now now as I type this it is taking upwards of 5-10 seconds. I suspect by 10pm tonight it will take roughly 20 seconds. It isn't like I am changing my flash version in the morning, afternoon, and night.

    You can clearly see the correlation between what time it is and how much lag there is. The later it gets the more lag that is introduced in to the game. I just cant see this being a issue that is on the surfer's side.

    I remember when you guys first launched the update. I couldn't log in to BP. You and Co. kept blaming my computer, my flash, my internet. The problem was me not kixeye. I then pointed out to you that I was able to log in to BP using the exact same set up but under a friend's account. What did that mean? The 4 or so days I couldn't access the game was indeed a fault of kixeye and not my setup. This whole lag situation reminds me of that, where you're diverting the blame to everyone else except for your machines.

    That being said, look at the posts. Look at the time the posts come in. You don't see lag issues during early morning / afternoon. You see them all at night, which is prime time. Start looking at your servers rather than passing the buck.

    If you must know:
    Computer 1:
    Dual Core 2.3ghz
    4GB Ram
    Lubuntu 12.x
    60GB SSD
    6mbps internet
    Connected via Wifi

    Computer 2:
    Quad core I5 - 4ghz
    16GB ram
    60G SSD System HDD
    225GB Raid 0 w/WD Raptors on an Areca Raid card for my home directory
    Lubuntu 12.x
    6mbps internet
    Connected via GB Lan

    The issues i have with lag happen on both machines.
  • Luis Pina
    Luis Pina
    Greenhorn
    Joined Oct 2011 Posts: 13
    the latest version of Flash (11.3), which introduced the ability to type in full-screen

    I just updated to 11.3 to check this and it's not true. There is no ability to type in full screen.
    As far as it comes to lag it's the same 1 version or the other. Yesterday there was no lag when I played and today it's taking me 1 minute or more to engage in a battle. I don't know what are you guys messing with but it's been unstable like this for weeks now.
  • Auditore
    Auditore
    Skilled Warrior
    Joined Jul 2011 Posts: 329
    I'm at 11.3 But I can't type in fullscreen I turned off HW acceleration didn't help I put it up to 10mb in flash settings only helps for a few mins then it was back to what it was before. Man Up Kixeye it's more then a flash issue.
    Retired at level 32
    Just an occasional Forum Visitor
  • Forbidden Warrior
    Forbidden Warrior
    Skilled Warrior
    Joined Mar 2012 Posts: 324
    Battle Pirates (retired): Ahoy. home sector: ??? I was banned lol Sectors visited: 2, 82, 112, 119, 120, 121, 153, 228, 264, 380, 386, 388, 432, 489 Raid Hulls Won: Battle Cruiser
    War Commander (retired): Look at my name. home sector: 25 Alliance: Brotherhood of NOD Raid Prizes Won: Elite Gatling Truck, honey badger & a puppy, but creeping on that shiny death bird the Warhawk ;) 
    Vega Conflict: Forbidden Warrior. home sector 6400 Home planet 6416
  • kandyman
    kandyman
    Potential Threat
    Joined Jun 2011 Posts: 94
    The asumption that lag issues started yesterday is erronious and misleading. The lag we have all (across all sectors) been experiencing is at least 7 days old as an issue.

    Thus the latest version of Flash is not the cause at all.

    The notion that inadequate user machines are the cause is also erroneous since any sensible game purveyor must design for 'average' ones or die due to lack of a big enough market and the same goes for internet connectivity.

    Projecting causes as all external to matters directly within Kixeye's control to resolve is just passing the buck, a 'red herring' and not helpful.

    Acknowledging the problem might well be internal within the game's own server/network/ infrastructure or, more likely, the sheer bloat of the code & loading, has way more credibility.

    Whatever the cause, this level of unplayability is just not acceptable and neither is it sustainable as any kind of business model. So something needs to be done about it and fast. The number of complaints spawning all over the internet now is simply staggering and way beyond the level I have ever seen about any on-line game in many years.

    Our sector's comms is constantly citing serious issues and I also experience them. Alliance pages are now full of complaints. It is a fact that many players, some surprise ones, too, since they are big, have already abandoned the game. I know big players (coiners) I haven't seen for days.

    So, for everyone's sakes, Kixeye, not least for your large number of paying players, myself included (in no small measure), please fix the 'playability' issue asap and best wishes with that endeavour.

    I love the game and understand all about teething issues, etc. They happen. But this matter is now way out of control and a real game killer. I am sad to say, if the game remains this unplayable for any longer my own patience will stretched to the absolute limit and I might just write off the huge amount of money spent supporting the game and just leave it be. It is now a complete head f***. Frustrating beyond belief and impossible to enjoy. Sorry, but true.


    i agree...now i have 9 dead fleets thanks to the lag...getting really ticked off!!!!!
This discussion has been closed.