Can't deploy units in enemy bases or can't see them deployed

Samurai Pizza Cat
Samurai Pizza Cat
Strike-force Captain
Joined Jul 2011 Posts: 631
Game loads, i can see inside my base and manage every buildings or other business, i can go outside to the map, the map loads fine, the chat works, but when i go inside bases , whatever base, if i attack that base and click on deploy some unit, ground or air i can't see that unit deployed.
Seems like i deploy nothing but that units was deployed cause if i return to my base that units is damaged or destroyed.
Cache cleaned, temp files deleted, tried other browsers (chrome, edge, maxthon, vivaldi, mozilla, opera), jumped to other sectors and tried attacking bases in other sectors, unistalled and reinstalled flash and java. AND THE SAME PROBLEM IN OTHER COMPUTER.
So i'm starting to think if this is a server game problem or something happens in my account. ???

Someone with the same problem? how did you solved it?

Sign In or Register to comment.