IMPORTANT - VEGA stops working in Firefox soon

CM Scarlett
CM Scarlett
Unicorn Overlord
Joined Mar 2014 Posts: 3,030
edited 17 Mar 2017, 2:52AM

Firefox will stop supporting NPAPI plugin with their Firefox 52 update. Players that update to this version will no longer be able to play VEGA Conflict on web through Facebook or KIXEYE.com.There are a few options to continue playing.

Option 1

You can continue playing VEGA Conflict on iOS, Android, or Steam. These platforms are NOT affected by Firefox dropping support to NPAPI plugin. Please see this guide for step-by-step instructions to link your account: https://vegaconflict.zendesk.com/hc/en-us/articles/215759867-Account-Linking-Guide

Option 2

If you don’t update to Firefox 52 you can continue playing as long as you’re running Firefox 51 or lower.

You can turn off Firefox’s auto-update to ensure it doesn’t auto update to Firefox 52. Please know, that this will prevent you from getting security updates from Firefox 52+.

Option 3

You can continue getting security updates for Firefox past the release date, but you must manually change your Firefox config from “Release” to “ESR”. See instructions here: Plugin Support in Firefox 52.

Please share this in comms with your friends and alliance members.


Submit ideas and feedback
>>>r/VEGAConflict<<<

  • John Jones22
    John Jones22
    Unicorn Overlord
    Joined Feb 2015 Posts: 3,291

    Thx for info scarlett, good looking out for the players.

  • gerard manjoue
    gerard manjoue
    Strike-force Captain
    Joined May 2016 Posts: 667
    3 ways to disable Firefox auto-updater:

    https://www.technipages.com/enable-disable-automatic-updates-in-firefox

    Please note it's highly hazardous to de-validate automatic updates whatever the software used, that's just be some kind of temporary move for your own security.
    image
  • Anastasisk
    Anastasisk
    Skilled Warrior
    Joined Jul 2015 Posts: 373

    Oh no, i play from Firefox cause steam is extremely lagish. Ill turn off auto updates for ever

  • Master Baku
    Master Baku
    Skilled Warrior
    Joined Oct 2015 Posts: 354

    Well I hope this doesn't kill vega for me. Steam isn't an option for me and mobile is no good sorry kix.

  • CORSAIR PT
    CORSAIR PT
    Potential Threat
    Joined Sep 2014 Posts: 28
    i m playing on linux ... with pipelight/wine ... with firefox  ... do you know something? i m praying that will affect me either and i cant play again :) and good news are: this time i will not return as last time
  • jackssson
    jackssson
    Greenhorn
    Joined May 2016 Posts: 6

    @CM_Scarlett : Does VC run with : opera, Chrome and IE ?

  • Playmaker1
    Playmaker1
    VC Mod
    Joined May 2015 Posts: 2,076

    @jackssson said:
    @CM_Scarlett : Does VC run with : opera, Chrome and IE ?

    IE can run Vega, according to some people. Chrome dropped Unity support a while ago. I don't know about Opera. It could work, but it's not a heavily used browser.

    Don't screw with me, I'm an Engineer. | Read this if you're jailed/banned. | Ore no Na wa Pureimēkā...
  • Lil Godson
    Lil Godson
    Potential Threat
    Joined Jan 2016 Posts: 28
    soo basically turn off Auto update forever? Got it..

  • jackssson
    jackssson
    Greenhorn
    Joined May 2016 Posts: 6

    @SEAL Corps1 said:

    @jackssson said:
    @CM_Scarlett : Does VC run with : opera, Chrome and IE ?

    IE can run Vega, according to some people. Chrome dropped Unity support a while ago. I don't know about Opera. It could work, but it's not a heavily used browser.

    Thanks.. maybe Opera is a Good Alternative to firefox

  • touche6784
    touche6784
    Skilled Warrior
    Joined Apr 2015 Posts: 477
    Also thanks to Mozilla for sticking it out for as long as they did. It's really sad the way big corps...like to force feed change all the time and everyone else who dislikes change has to "deal with it" or "get with the times"

    For a minute I thought you were talking about Kixeye.
  • HunterKiller69
    HunterKiller69
    Skilled Warrior
    Joined Apr 2016 Posts: 344
    perfect, just perfect. just when i find out you can play on Firefox, this happens
    ░░░░░░███████ ]▄▄▄▄▄▄▄▄▃
    ▂▄▅█████████▅▄▃▂
    I███████████████████].
    ◥⊙▲⊙▲⊙▲⊙▲⊙▲⊙▲⊙◤...
  • zoli200000
    zoli200000
    Greenhorn
    Joined Aug 2015 Posts: 4
    Vega Conflict in Internet Explorer 11 on Windows 10 work well.
    As for Firefox, just turn off automatic updates if it is not your favorite brwser.
    In my case I use Chrome as my default browser, so I have no problem to turn off updates in Firefox.

    For the other browser currently, I can confirm that no works Vega confllict.

    Currently the only browser that supports Vega are:

    • Internet Explorer 11
    • Safari
    • Opera (version 36 and older)
    • Firefox 32bit
    Unsupported Browsers

    Chrome: As of version 45, Chrome no longer supports the Unity Web Player.

    Microsoft Edge: Microsofts new broswer, Edge, does not support the Unity Web Player.

    Firefox 64bit

    Firefox 32bit: As of Version 53 and newer

    Opera (version 37 and newer)


  • gerard manjoue
    gerard manjoue
    Strike-force Captain
    Joined May 2016 Posts: 667
    edited 10 Feb 2017, 9:19AM
    Once more, disabling auto updating feature should only be a temporary patch during the time you find another way to play. Even with automatic updates, do you know that Firefox is the most unsecured - that is tackled -  browser and you'll certainly not enforcing your global browsing security by doing that?

    Anyway, if you're going to disable auto updates, use only Firefox to play your favorite game and never to browse Internet because you would be at risk.

    Firefox had less than 10% of browser market share but had 33% of browser vulnerability in 2013:
    http://www.whoishostingthis.com/blog/2014/12/09/most-secure-browser/


    image
  • jboder
    jboder
    Skilled Warrior
    Joined Sep 2015 Posts: 329
    recommending to turn of auto update and open lots of security holes - wow, well done!
  • Milo_ja
    Milo_ja
    Incursion Leader
    Joined Dec 2015 Posts: 1,180
    edited 10 Feb 2017, 10:09AM
    soo basically turn off Auto update forever? Got it..

    Or in other words: use FF for VC, use Chrome for anything else, to browse safe. :)
  • Bolocool
    Bolocool
    Minor Nuisance
    Joined Oct 2016 Posts: 138
    Scarlett, why the game isn't supported on Linux Steam? That's too much trouble to use Firefox with Wine there and even this option is dying.
  • Chili Industries Ltd
    Chili Industries Ltd
    Strike-force Captain
    Joined Feb 2014 Posts: 646
    Guys, v52 is not the end of NPAPI for Firefox. It will still be possible to use it and leave the auto update on. Follow the links provided by Scarlett to learn more about it. Just as there used to be with Chrome, there will be a way to turn plugin support on. It will be the end with v59, but up until then you can still use it.

    Links again, in case you missed them:

    Mozilla to Drop Support for All NPAPI Plugins in Firefox 52, Except Flash
    Plugin Support in Firefox 52
  • Dayspring329
    Dayspring329
    Strike-force Captain
    Joined Apr 2012 Posts: 670
    What will happen to this forum? Will there ever be a link from Steam to it?
    photo forumbanner-2.jpg
  • Dragonfireforce
    Dragonfireforce
    Greenhorn
    Joined Sep 2013 Posts: 15
    This doesnt make sense. stop working on firefox? Steam i cant log into to play vega. Been trying to clear cache and all, tried to log in for 4 hours, no luck. Only way to play is on firefox browser. no wonder people gonna quit playing the game.
  • touche6784
    touche6784
    Skilled Warrior
    Joined Apr 2015 Posts: 477

    On March 7th, Firefox will stop supporting NPAPI plugin with their Firefox 52 update. Players that update to this version will no longer be able to play VEGA Conflict on web through Facebook or KIXEYE.com.There are a few options to continue playing.

    Option 1

    You can continue playing VEGA Conflict on iOS, Android, or Steam. These platforms are NOT affected by Firefox dropping support to NPAPI plugin. Please see this guide for step-by-step instructions to link your account: https://vegaconflict.zendesk.com/hc/en-us/articles/215759867-Account-Linking-Guide

    Option 2

    If you don’t update to Firefox 52 on March 7th you can continue playing as long as you’re running Firefox 51 or lower.

    You can turn off Firefox’s auto-update to ensure it doesn’t auto update to Firefox 52. Please know, that this will prevent you from getting security updates from Firefox 52+.

    Option 3

    You can continue getting security updates for Firefox past March 7th, but you must manually change your Firefox config from “Release” to “ESR”. See instructions here: Plugin Support in Firefox 52.

    Please share this in comms with your friends and alliance members.


    Why don't you focus on vega working on Steam like every other game available and preventing people from cheating with their mobile devices like they did to get the unlimited free coins from videos. 
  • marton.keri
    marton.keri
    Skilled Warrior
    Joined Apr 2015 Posts: 525
    When I saw the announcement, first I only read "IMPORTANT - VEGA stops working", and I though we were right bwahaha, but then I kept reading...
  • HappyClappy
    HappyClappy
    Greenhorn
    Joined Apr 2013 Posts: 14
    Hi, or use IE 11... works like a charm. Edge refuses but IE 11 runs beautifull. :)
  • BirdhouseNest
    BirdhouseNest
    Skilled Warrior
    Joined Aug 2016 Posts: 300
    You spelled "Steam February" wrong
    #TeamFRIENDKNOWN - What did the aliens ever do to us Rebels?
  • Handoff2018
    Handoff2018
    Greenhorn
    Joined Sep 2015 Posts: 4
    Well, I see this announcement and Steam seems to be broken as I haven't been able to log in on either computer.  I guess rather than just ruin the game and chase us away, they are trying to just make it so we can't play it at all.
  • Shrike157
    Shrike157
    Skilled Warrior
    Joined Oct 2016 Posts: 400

    @touche6784 said:
    CM_Scarlett said:

    On March 7th, Firefox will stop supporting NPAPI plugin with their Firefox 52 update. Players that update to this version will no longer be able to play VEGA Conflict on web through Facebook or KIXEYE.com.There are a few options to continue playing.

    Option 1

    You can continue playing VEGA Conflict on iOS, Android, or Steam. These platforms are NOT affected by Firefox dropping support to NPAPI plugin. Please see this guide for step-by-step instructions to link your account: https://vegaconflict.zendesk.com/hc/en-us/articles/215759867-Account-Linking-Guide

    Option 2

    If you don’t update to Firefox 52 on March 7th you can continue playing as long as you’re running Firefox 51 or lower.

    You can turn off Firefox’s auto-update to ensure it doesn’t auto update to Firefox 52. Please know, that this will prevent you from getting security updates from Firefox 52+.

    Option 3

    You can continue getting security updates for Firefox past March 7th, but you must manually change your Firefox config from “Release” to “ESR”. See instructions here: Plugin Support in Firefox 52.

    Please share this in comms with your friends and alliance members.

    Why don't you focus on vega working on Steam like every other game available and preventing people from cheating with their mobile devices like they did to get the unlimited free coins from videos. 

    How about no, some people like me play almost exclusively on mobile

    Member of [TM16R] damned - Part of FFF - VIP Rank 1 - Base Level 59

    "Let your plans be dark and impenetrable as night, and when you move, fall like a thunderbolt" -Sun Tzu (The Art of War)
  • Shrike157
    Shrike157
    Skilled Warrior
    Joined Oct 2016 Posts: 400

    @Bolocool said:
    Scarlett, why the game isn't supported on Linux Steam? That's too much trouble to use Firefox with Wine there and even this option is dying.

    @CM_Scarlett plz read, this affects me too

    Member of [TM16R] damned - Part of FFF - VIP Rank 1 - Base Level 59

    "Let your plans be dark and impenetrable as night, and when you move, fall like a thunderbolt" -Sun Tzu (The Art of War)
  • CM Scarlett
    CM Scarlett
    Unicorn Overlord
    Joined Mar 2014 Posts: 3,030
    3 ways to disable Firefox auto-updater:

    https://www.technipages.com/enable-disable-automatic-updates-in-firefox

    Please note it's highly hazardous to de-validate automatic updates whatever the software used, that's just be some kind of temporary move for your own security.
    If you switch to the LTS (long term support) stream, you should be able to continue to play VC while still getting security updates. It looks like 52.x LTS will be around for at least another year.
    Submit ideas and feedback
    >>>r/VEGAConflict<<<

Sign In or Register to comment.